spigot rings??

PaulF

Newbie
Points
56
Hi All, hopefully someone can shed some light on this prob. i have 15" TSW alloys fitted to my 206. when driving on uneven roads there is a lot of load noisy metalic banging. i was told that i need to fit spigot rings to the alloys to stop this noise. i was told that i need OD 72.1mm and ID 65.1mm rings so i bought them only to find that they dont fit. infact there is no room for spigot rings to fit at all. the inside diameter of the alloy is the same as the raised section of the wheel hub.

ok so i cant fit spigot rings any idea how i can stop this horrible noise???
 

Prince

Torque King
Points
242
Location
Northampton, England
Car
BMW E36 318is Coupe
Alright mate...welcome to TorqueCars! Are the alloys fitted properly? Did you check that the alloys would fit the car properly before fitting them? Have you checked for a loose parts around the wheel?
 

PaulF

Newbie
Points
56
Hi guys ... thanks for all of your posts. New lower suspension arm on both sides, new track rod end ball joint both sides, all wheel checked and very tightly secured. Sounds like the noise is coming from all wheels. Is it possible that the wheels were supplied particularly for my car but does not fit too well hence the noise. No room to fit spigot rings which is what I tried to do!!!

I am a driving instructor and use it for lessons. The students love the look of it but all worry about the noise.
 

thexav

Pro Tuner
Staff member
Points
387
Car
2002 Clio 172
Sounds like the wrong wheels if the noise is coming from each corner. Can you see whats rubbing? Are the brakes clearing ok? Do the wheels wobble when they are jacked up.
 
Top