Small loss of power/Surging problem! 9-3 linear

SaabSon

Wrench Pro
Points
26
From
Southern California
Car
04 Saab 9-3 2.0t
So...I noticed today as I was driving about 70mph on the freeway, with a steady foot on the gas pedal, that the car was having split second losses of power. It seemed as if the car was surging. The surge is small. The boost on the turbo gauge, goes up and down the slightest but I can still feel the car loosing power sporadically! I'm going to try and sort things out tomorrow. I'm thinking I could have a fuel pump on it's way out, a plugged filter somewhere, throttle body fault, or something MAF or vacuum related...That's what came to mind.

Have any of you guys had a similar problem? Any direction would be very much appreciated!

The car is a 2004 9-3 linear with 150k miles on it btw.
 

T9 man

TC ModFather
Moderator
Points
1,137
From
London, UK
Car
Saab 9-3SS T9
Check the vacuum pipes near the turbo and the APC valve. Make sure all hoses clips are tight and slowly check the hoses for any splits. Some of those splits are hard to see so make sure you squeeze the hose as you are checking it. If you have an intercooler fitted make sure you check that pipework also.
 

TCJBOLDIE

Torque King
Points
667
From
Brisbane
Car
JB Starion
Sometimes you can locate a leak by spraying soapy water on the hoses and connections while the motor is running as it will make bubbles where there are leaks
 

93SPORTSEDAN

Full member
Points
16
From
Belgium, Wilrijk
Car
saab 93 2.2tid
if it's a diesel, you should check your egr valve... As I have had the same problem of power loss and it was the EGR valve... If not I can't help man.... Good luck!
 
Top