Torque Cars

Response Problem with PFC Ecu...HELP!

Discussion in 'Lancer EVO forums' started by Nobita, 20 April 2012.

  1. Nobita

    Nobita Newbie

    Messages:
    2
    From:
    Singapore
    Car:
    Evo V
    Honestly, i am really disappointed on how my car response as whenever i full pedal on 1st, 2nd or 3rd gears my car will always deep (suddenly became tremendously heavy) and the Afr's goes rich on my PFC ecu...

    Help!!!! What happening with this ecu!!!!

    Ive tried reducing fuel & advancing timing on the lower load cel but its still the same. My car just cant go for immediate WOT and ive to keep doing partial lift off and pedal again and only then my car catapult!

    Will this issue cause by TPS??? My current TPS reading on stationary with ignition ON but not started : 9.019%
    TPS reading on Full Pedal with ignition ON but not started : 92.156

    HELP as this issue have been hunting me for Months.....

    Thanks
     
  2. T9 man

    T9 man TC Pro Founder Moderator

    Messages:
    20,369
    From:
    London, UK
    Car:
    Saab 9-3SS T9
    Greetings and Welcome to our TorqueCars Forum my Friend! :)

    I am unable to help you with your question directly, but hopefully somebody can point you in the right direction for the knowledge that you seek!

    Good luck! :)
     
  3. Nobita

    Nobita Newbie

    Messages:
    2
    From:
    Singapore
    Car:
    Evo V
    Thanks T9...:D
     
Loading...

Share This Page

Click Here
  1. This site, like pretty much every other site, uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are agreeing to our use of cookies, this may include third party cookies from our carefully selected advertising partners and for our analytics which allow us to see which pages are of interest and improve our site navigation and experience.
    You can disable cookies in your browser but this may affect your experience on this website.

    Dismiss Notice