Torque Cars

need help A.S.A.P

Discussion in 'Lancer EVO forums' started by davy, 19 July 2009.

  1. davy

    davy Wrench Pro

    Messages:
    23
    From:
    ireland kells
    Car:
    evo 7
    i have a evo 7 400bhp
    my problem is with the drivetrain when it is cold it is fine but after about half hour of driving around town when turning around corners slowly the front wheels start clickin as if the cv joints are gone but there fine.
    i got a few people saying it was the diff in the gearbox but as i have the box out the diff looks fine it just looks standard,anybody have this problem let me know cheers asap
     
    Last edited by a moderator: 19 July 2009
  2. turbonutter69

    turbonutter69 TC ModFather Moderator

    Messages:
    18,967
    From:
    Alone in the dark.
    Car:
    Insignia SRI.
    I'd check the driveshafts. Have a look also at the steering rack.

    Just a quick note please refrain from using text speak as it makes it harder to read the post. Cheers mate. :)
     
  3. davy

    davy Wrench Pro

    Messages:
    23
    From:
    ireland kells
    Car:
    evo 7
    iv'e cheeked all that there all fine,it only happen's when it gets warm
     
  4. turbonutter69

    turbonutter69 TC ModFather Moderator

    Messages:
    18,967
    From:
    Alone in the dark.
    Car:
    Insignia SRI.
    What about the driveshaft where it meets the gearbox? It's quite strange as it only does it when warm? Have you checked the engine mounts?
     
  5. davy

    davy Wrench Pro

    Messages:
    23
    From:
    ireland kells
    Car:
    evo 7
    ye there fine,i was told that ther is a competition diff in the box,and it only makes noise cause of the plates in the diff get warm and start bangin off each other and thats the noise,know that i have the diff out im not sure what im lookin at
     
  6. pgarner

    pgarner TC ModFather Moderator

    Messages:
    16,521
    From:
    Lockerbie, SW Scotland
    Car:
    Octy smoke machine
    Stupid question
    is there oil in the Gearbox / diff ?
     
  7. davy

    davy Wrench Pro

    Messages:
    23
    From:
    ireland kells
    Car:
    evo 7
    i found the problem with my gearbox,
    all the power is going to the back wheels
     
  8. turbonutter69

    turbonutter69 TC ModFather Moderator

    Messages:
    18,967
    From:
    Alone in the dark.
    Car:
    Insignia SRI.
    Broken diff?
     
  9. davy

    davy Wrench Pro

    Messages:
    23
    From:
    ireland kells
    Car:
    evo 7
    no the box is perfect,it's just the way they set it up in japan.more than likely for driftin they set the diff in the box to spin the front wheels at the same speed (as in a locked diff)
    just sell that box i got a standard box last weekend,put new bearings in it yesterday.
    Just waitin on my clutch and i while be back on the road shuld have it wed
     
  10. turbonutter69

    turbonutter69 TC ModFather Moderator

    Messages:
    18,967
    From:
    Alone in the dark.
    Car:
    Insignia SRI.
    Ahh ok sweet.
     
Loading...

Share This Page

Click Here
  1. This site, like pretty much every other site, uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are agreeing to our use of cookies, this may include third party cookies from our carefully selected advertising partners and for our analytics which allow us to see which pages are of interest and improve our site navigation and experience.
    You can disable cookies in your browser but this may affect your experience on this website.

    Dismiss Notice