Heater Resistor Module.

Reshan1809

Newbie
Points
6
From
Mauritius
Car
Citroen C5
Hello, there.
Am Reshan from mauritius.

Currently driving a citroen c5 with a DW10ATED engine, almost same as the peugeot 406.
Came by here, because citroen forum seems a bit dull, haha :p

Well, am having problems with my climate control.
As when I switch on, A/C should come up (if on obviously) with the blower running too. But instead, it all goes off and after a while (no indication of fan blades on dash) and the blower not running.

I went down to the driver side and landed on the heater resistor module, seemed to work fine( I don't know), 12V seems to be coming from the feed wires (upper plug, Red & Black wire)..

But the wires which hook up to the blower does not seems to have a voltage in them.

So I took a 12V feed from the glove box and connected it the wire, everything worked fine..
Blower is only running on a separate 12V feed connected accross it.
(blower speed and so can also be regulated, so guess it's not the resistor box, don't really know)

Can anyone help me here please.
 

T9 man

TC Pro Founder
Moderator
Points
1,077
From
London, UK
Car
Saab 9-3SS T9
Greetings and a Warm Welcome to our TorqueCars Forum my Friend! :)

I am unable to help you with your question directly, but hopefully somebody can point you in the right direction for the knowledge that you seek!

Good luck buddy! :)
 

Reshan1809

Newbie
Points
6
From
Mauritius
Car
Citroen C5
Thank you T9.
Any diagram of the climate control system help also.
Trying the hard way before the easy way(getting a relay to manually power the blower)
:p
 
Top