Torque Cars

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies.

    Learn More.
  2. Dismiss Notice
  1. JalbKay

    JalbKay New member

    Messages:
    5
    From:
    Townsville, AU
    Car:
    MX5 NC 2.5L SC
    Wish I'd found this forum several years ago. Other sites/forums I've visited don't really seem to like 'breaking it down' for the novices and advice is usually "if you don't know take it to a mechanic", but I digress ;)

    Chris from Australia. 2006 MX5 NC (Mk3) Engine swapped 2.5L,
    Full GWR Roadstersport header to exhaust (Max power, Helmholtz mid and SuperQ)
    550cc Grams Performance Fuel injectors
    265 LPH Grams Performance Fuel Pump
    Rotrex C30-84 Supercharger and Intercooler
    Stock ECU tuned by Mike at Moto-East
    Stock auto with ~2400 stall
    SportsRyder eXtreme XA Adjustable Coil Overs
    Hankook Ventus S1 Noble2 205/45 R17 Fronts
    Hankook Ventus S1 Noble2 245/45 R17 Rears (rolled guards)

    With the help of the intarwebs, various forums, google and YouTube I've done all the work myself... except the suspension and tyre changes, which I would of had a crack at had the wife let me buy a hydraulic hoist :D Suffice to say I've learned a lot over the last 6 years when I first upgraded the exhaust to now, having just finished the SC install. I've had various engines in and out 4 times:
    first 2.5 dropped a valve head and pretty well destroyed pot one, 2.0 went back in. Next 2.5 (Mazda3 SP25, low km) went in, developed a knock after 2.5K km, apparently the engine run this was from had dodgy conrod bearings, took it out and replaced them with quality race bearings and has purred since.

    Don't know what sort of power I'm producing, being new to boost I'm not sure everything is 'quite' right. Can't get positive pressure. Makes all the right noises, feels like it's got more, but that could just be fueling and timing, but boost/vacuum gauge never passes 0. Gauge has been tested, intake and inter-cooler path all hold pressure and the SC belt has good tension. Logs tell me MAP is 110kPa at peak which is only ~2 Psi. I feel it could be a soft BOV as it definitely did more when I took vacuum off and blocked it but could also be the main serpentine slipping on the water pump pulley (SC belt is toothed and just can't slip). Anyway, I'm putting her on the dyno tomorrow, hopefully the guy that runs the performance shop will have some pointers ;) The 2.0 with exhaust was 97rwkW, with tune it hit 113rwkW (150hp), will be interesting to see what the 2.5 does.

    Anyway, long post, life story etc. Hope to be able to get help and help out where able so cheers.
     
    TCJBOLDIE and Lunchmoney like this.
  2. Lunchmoney

    Lunchmoney Torque Master

    Messages:
    925
    From:
    Poole, UK
    Car:
    '98 JDM Impreza STI
    Hello and welcome!

    Certainly looks like you know your way around a car and should be good to help others with questions :)


    to be fair, this is usually correct, at least to have a chat and get some advice :)
     
    JalbKay likes this.
  3. TCJBOLDIE

    TCJBOLDIE Torque King

    Messages:
    4,308
    From:
    Brisbane
    Car:
    JB Starion
    You could remove the BOV and cap it off and then see if it makes boost.
    Are you sure that there are no leaks or splits in the intercooler system ??

    Have you had a smoke test to find where there are any leaks?
     
    Lunchmoney likes this.
  4. JalbKay

    JalbKay New member

    Messages:
    5
    From:
    Townsville, AU
    Car:
    MX5 NC 2.5L SC
    Hi Boldie, yeah, have just done that. Found the throttle body had loosened as well so that’s been torqued and thread locked. Now consistently topping out MAP at 118.6 kPa (~3Psi)

    As sure as I can be mate. I had it holding 15Psi and could hear nothing but I’ve not had a smoke test; I may have to find a local shop to get it done properly.
     

Share This Page

Click Here