erratic idle

karl1127

Full member
Points
46
Location
england durham
Car
mitsubishi gto
I have read a post on here that says he has erratic idle speed ,my car has the same problem but it is only when it is cold ,when warm there is no noticeable problems, if i don't touch the throttle the car would and does cut out, there is no response to the previous post ,just wondered if anyone has any idea,mine is a gto 3lt n/a,in case someone can point me in the right direction ,any help would be welcome,thanks Karl
 

herb

modherbrator
Moderator
Points
477
Location
west midlands
Car
Seat Leon Cupra
cant really say for the gto! but i had erratic idling on my astra and this was caused by the icv (idle control valve) which became quite embarrassing:embarrest: i would pull up at some lights and the car would rev to the limiter then stall then i would start it up again and again the same:embarrest:
i was told by a mate 2 options
1 go for a hard drive down some a/b roads for a good 30 mins (this worked for me
2 was take the icv of and give it a good clean
 

karl1127

Full member
Points
46
Location
england durham
Car
mitsubishi gto
It's the same with the vectra [do all vauxhalls have this problem ] ,but this is only happening on the gto when the car is cold , after,a few mins it works fine ,i suspect it must be something to do with the cold start system,have checked all the vacuum pipes and all seem to be ok, if you hold your foot on the throttle for a few seconds and hold it at about 1500rpm for a few seconds it seems to settle down,again any help would be welcome
 

johhnnie

Full member
Points
21
Location
scotland , clackmannan
Car
gto tt
Common fault on vectras i was told by a vauxhall mech ( clean out the breather pipe lower end of carb on right side looking in from engine bay , He put a small drill into the brass pipe and there was loads of carbon build up in there , once clear idle was ok .

You can only try , it might be the same problem:D
 

karl1127

Full member
Points
46
Location
england durham
Car
mitsubishi gto
mmmmm, don't think that the idle control valve would look or could be fixed the same way as a vectra ,i have cured loads of vectras with the cleaning of the icv but even the later vectras have a different icv than the older models,the newer one has to be changed to fix the problem,however,-- where is, or does, the gto even have a icv,the closest thing that i can see has three connectors going to it,and its something that i would not touch if i am not 100% sure,was hoping someone has had the same problem and then fixed it ,the problem is not that it won't tick over all of the time its only when you start the car from cold,after that the car runs fine ,but thanks for the input,
 

karl1127

Full member
Points
46
Location
england durham
Car
mitsubishi gto
I stand corrected ,the I.C.V can be cleaned in the same way as a vectra,my apologies for jumping the gun!!!, i removed the big main intake pipe and there it was ,two 8mm bolts held it into position ,these were removed and out it came ,removed the three screws from the back and it came apart ,[mind the spring ] gave it a good squirt of brake cleaner,a quick wipe ,and replaced the three screws that hold it together, i then gave the nipple shaped end a good clean ,this was harder to clean as the black carbon was quite thick on this part,finally got it all off ,put it back together and hey presto everything is fine and it ticks over as it should ,job done
 

kb277

New member
Points
31
Location
Inverness
Car
GTO TwinTurbo
awe nice one!!! i've jsut joined this forum today and this was one of my main bugs about my gto (twinT) i have exactly the same issue when started from cold. It cuts out until i drive prob about 150 yards then it seems to be fine. Going to try find this breather pipe and clean it out right now Cheers for this thread :)

Prob number 1 down about 15 niggly things to go lol
 

karl1127

Full member
Points
46
Location
england durham
Car
mitsubishi gto
Hi kb277 ,it is not a pipe that i cleaned,it is the icv unit itself that i cleaned,the pipe i removed to access the icv was the main air intake pipe,the icv unit is attatched to the trottle body itself ,mine was a brown colour ,but i have seen the same icv in black,it has also been called a stepper motor,in other posts i have read,hope this helps---Karl
 

Country Bumpkin

Track Warrior
Points
187
Location
Norfolk
Car
GTO T.T.
DSC00104.jpg


It's one of these and sits at the bottom of the throttle body. :)
 

Country Bumpkin

Track Warrior
Points
187
Location
Norfolk
Car
GTO T.T.
This is where it locates and if you look inside you will see oil deposits which have passed into the throttle body and collected onto the sensor of the Idle Control Valve. This is why the problems start. The actual body needs to be cleaned or the problem will just re-occur at some stage.

DSC00090.jpg
 
Similar threads
Thread starter Title Forum Replies Date
A erratic idle GTO/3000GT Forums 0

Similar threads

Top