DS3 2016 and newer induction kits?

AntonJRAndersson

New member
Points
13
Location
Sweden
Car
Citroen DS3 1.6 THP
Hi!

Does anyone know if there are any cold air intakes/induction kits for the 2016 model and later of the DS3 1.6 THP 165?

I recently bought a Forge motorsport induction kit hoping that it would somehow magically work for my car (which it didn’t).

I really crave that sweet sweet induction sound!

Thankful for any help!
 

obi_waynne

Administrator
Staff member
Moderator
Points
1,157
Location
Deal, Kent UK
Car
A3 1.4 TFSI 150 COD
Does the 1.6 THP produce an induction roar - a lot of PSA group engines are quite refined and sip the air intake nowadays, not like the days of the Saxo VTR's etc...?

If you take off the filter box to try it out is that the sound you want?

These kits won't add power but I guess you know that and it's the sound you seek. K&N do a filter that fit these IIRC, annoyingly it will suck in warm engine bay air though so you'll need to fabricate a cold air feed to it.
 

AntonJRAndersson

New member
Points
13
Location
Sweden
Car
Citroen DS3 1.6 THP
Does the 1.6 THP produce an induction roar - a lot of PSA group engines are quite refined and sip the air intake nowadays, not like the days of the Saxo VTR's etc...?

If you take off the filter box to try it out is that the sound you want?

These kits won't add power but I guess you know that and it's the sound you seek. K&N do a filter that fit these IIRC, annoyingly it will suck in warm engine bay air though so you'll need to fabricate a cold air feed to it.
I did try the Forge induction kit on just in case it would magically work and it sure did sound amazing, unfortunately the engine didn’t like it very much as the sensors freaked out.

Will look into doing some custom solution unless someone has any other ideas!
 

obi_waynne

Administrator
Staff member
Moderator
Points
1,157
Location
Deal, Kent UK
Car
A3 1.4 TFSI 150 COD
I did try the Forge induction kit on just in case it would magically work and it sure did sound amazing, unfortunately the engine didn’t like it very much as the sensors freaked out.

Will look into doing some custom solution unless someone has any other ideas!
The problem could well be an air sensor or probably a fuelling issue, it's not uncommon for the extra air to cause the engine to run lean on these. I did hear from one guy in a similar situation who had problems until he upgraded the exhaust and this resolved his issues.

Glad it sounded great, I will note that if anyone else asks.

With most mods you need to run them in the car for a bit after an ECU reset to allow everything to retrim and set itself up. I would say this means around 200miles, but if you're getting serious errors and limp home mode that would not be practical.
 
Top