AC just stopped working

trumpet30

Wrench Pro
Points
36
Car
VW Polo 1.4TDI
Hi I have a 58 reg fiesta and API switched on my AC that was working last week and now it's not. The fuse is fine and I have checked the pressure in the system (I have a top up unit with gauge) so I know it's not loss of refrige. The light on the AC button works so how can I test if I have a faulty pressure sensor or clutch. Is there anything else worth checking.
 

herb

modherbrator
Moderator
Points
487
Location
west midlands
Car
Seat Leon Cupra
some ac systems stop working when the outside temperature reaches a certain temperature not sure on your fiesta but on mine it's 5°c iirc
 

trumpet30

Wrench Pro
Points
36
Car
VW Polo 1.4TDI
It's a top up unit with pressure valve that connects/pierces a can of r134a.

It does have obd2 but it looks like the car does not support ac diagnostics.
 

T9 man

TC ModFather
Moderator
Points
1,137
Location
London, UK
Car
Saab 9-3SS T9
I think herb is right about the AC cut-off point buddy, mine refuses to work down to a certain temperature but I never made a note of the exact temperature. If you are able to contact your Ford main dealer then they might be able to shed some light on this for you. In the meantime I shall ask a friend at work who has a daughter with a Fiesta if they can look in the manual to see if anything is mentioned about it.
 
Similar threads
Thread starter Title Forum Replies Date
H cluster gauge not working!!!! Technical forum 4

Similar threads


Please watch this on my YouTube channel & Subscribe.


Top