620Ti battery problem

turbonutter69

TC ModFather
Moderator
Points
692
Location
Alone in the dark.
Car
Insignia SRI.
thanks mate ill try that how many is there

I'm not sure exactly but there is a few more dotted around the car. I've only just got mine so it's a learning curve for me too. Although I have been doing some research on them for a while. Get yourself on ebay and buy the repair manual cd. I got 1 the other day for 3 quid. It arrived the next day too. Haven't had the chance to have a good look at it yet though.
 

obi_waynne

Administrator
Staff member
Moderator
Points
1,157
Location
Deal, Kent UK
Car
A3 1.4 TFSI 150 COD
Just a thought its not the starter motor trying to draw too much current? Its worth checking and would mean the battery needs to be 100% to work it.
 

azzy

Torque Junkie
Points
65
Location
sheffield
Car
rover 620ti
i got this man today to see wat drain the battery and he says the alternator in gone. its running 31 amps. and it should be running abt 55 amps is that right wound u say
 

turbonutter69

TC ModFather
Moderator
Points
692
Location
Alone in the dark.
Car
Insignia SRI.
i got this man today to see wat drain the battery and he says the alternator in gone. its running 31 amps. and it should be running abt 55 amps is that right wound u say

I'm unsure at the min as to what they actually run at but I know a ti alternator is an 85 amp unit....
 

azzy

Torque Junkie
Points
65
Location
sheffield
Car
rover 620ti
yes am gona try one tomoz. is it hard fitting 1. i use all spanners and know abt engines never done 1 tho
 

turbonutter69

TC ModFather
Moderator
Points
692
Location
Alone in the dark.
Car
Insignia SRI.
also i got a turbo boost gauge but how do i fit it

The alternator is a fairly easy job. Just make sure you get the belt tight enough but not tooo tight. Did you get some boost pipe and a 3 way connector? If so feed the pipe from engine to wherever your mounting the gauge. Then cut small pipe that comes out your dunp valve and attach the 3 way adaptor to the pipe you have just cut and the pipe that goes to your boost gauge....Simple.....
 

turbonutter69

TC ModFather
Moderator
Points
692
Location
Alone in the dark.
Car
Insignia SRI.
yeh i got all that and 3 way connector. but ill do the boost controller next time

Right the thin pipe is boost pipe...This needs to go from your engine into the car where you are going to mount the gauge. Next there is a pipe the same as the 1 you've got with the gauge coming out of the Dump Valve. You need to cut this pipe and attach it to the three way connector and also connect the new pipe to it. Connect new pipe to boost gauge and wire the illuminaation up and jobs a good un......
 

azzy

Torque Junkie
Points
65
Location
sheffield
Car
rover 620ti
ohh so i get the dump valve pipe cut in half then put the 3 way in between get the new pipe in dump vave 3 way connector then up to gauge
 

azzy

Torque Junkie
Points
65
Location
sheffield
Car
rover 620ti
thanks mate thats all gd. ill do that tommoz. do u no where the lamba sensor is and temp sensor my petrol is killing at 13 miles to a gallon. my car is all standerd
 

turbonutter69

TC ModFather
Moderator
Points
692
Location
Alone in the dark.
Car
Insignia SRI.
thanks mate thats all gd. ill do that tommoz. do u no where the lamba sensor is and temp sensor my petrol is killing at 13 miles to a gallon. my car is all standerd

Erm unsure as of yet but watch this space. I'm gonna have a look at the workshop cd tomorrow so will let you know then. Do you have a heavy right foot?
 
Similar threads
Thread starter Title Forum Replies Date
A 620ti help 600 19
A Testing a Lambda sensor 620Ti 600 28
turbonutter69 620ti Forum? 600 4
turbonutter69 Where's all the 620ti owners? Any out there? 600 10
turbonutter69 Engine fan 620ti 600 19

Similar threads


Please watch this on my YouTube channel & Subscribe.


Top