620Ti battery problem

azzy

Torque Junkie
Points
65
Location
sheffield
Car
rover 620ti
hi can anyone help me plz i own a rover 620ti on 99 plate. its all standerd . and done 128k , but my batterys keeps going flat after new ones fitted. like 3 days only then new one . wat can that be . i tested it 12.7 volts car off. thanks
 

turbonutter69

TC ModFather
Moderator
Points
692
Location
Alone in the dark.
Car
Insignia SRI.
Re: 620 Ti??

hi can anyone help me plz i own a rover 620ti on 99 plate. its all standerd . and done 128k , but my batterys keeps going flat after new ones fitted. like 3 days only then new one . wat can that be . i tested it 12.7 volts car off. thanks


Right does your battery light on the dash board stay on? Have your got a stereo or an amp in the car? Has it got an alarm fitted? It could be a number of things but these listed are the most common problem with batteries
 

azzy

Torque Junkie
Points
65
Location
sheffield
Car
rover 620ti
Re: 620 Ti??

i use to have a 4000 watts amp and sub but i took it out after the battery went. and no lights on dash, how can i test it on volt meter that there is no power leaking over night. coz i have to buy a battery every 4 days . so i disconnect it from the battery all wires.
 

turbonutter69

TC ModFather
Moderator
Points
692
Location
Alone in the dark.
Car
Insignia SRI.
Re: 620 Ti??

i use to have a 4000 watts amp and sub but i took it out after the battery went. and no lights on dash, how can i test it on volt meter that there is no power leaking over night. coz i have to buy a battery every 4 days . so i disconnect it from the battery all wires.

Did you have the car running when you tested the battery?
 

azzy

Torque Junkie
Points
65
Location
sheffield
Car
rover 620ti
Re: 620 Ti??

yeh mate with being off 12.7 volts and then when i started it running its 13.3 wat can it be
 

azzy

Torque Junkie
Points
65
Location
sheffield
Car
rover 620ti
Re: 620 Ti??

yeh its got standerd alarm and stereo. i took the amp out of car but wires still in boot with tape around it.
 

turbonutter69

TC ModFather
Moderator
Points
692
Location
Alone in the dark.
Car
Insignia SRI.
Re: 620 Ti??

yeh its got standerd alarm and stereo. i took the amp out of car but wires still in boot with tape around it.


How was the amp wired in? Did you have Power from Bat to amp. Remote from head unit to amp and the earth from amp to earth in boot? The alarm could be faulty. Have you replaced the battery? Was it a brand new battery you replaced it with?
 

azzy

Torque Junkie
Points
65
Location
sheffield
Car
rover 620ti
Re: 620 Ti??

yeh mate all that was right wired up .and the alarm am not sure if that is any problems coz its standerd
 

azzy

Torque Junkie
Points
65
Location
sheffield
Car
rover 620ti
Re: 620 Ti??

honest mate i tryed all that . yeh things works in car i off the inside light . how do i try to test if anything is running overnight. is there a test for volt meter or something
 

turbonutter69

TC ModFather
Moderator
Points
692
Location
Alone in the dark.
Car
Insignia SRI.
Re: 620 Ti??

honest mate i tryed all that . yeh things works in car i off the inside light . how do i try to test if anything is running overnight. is there a test for volt meter or something

Maybe a daft question but is the battery still under the bonnet? So did you mean all the electrics work in the car?
 

azzy

Torque Junkie
Points
65
Location
sheffield
Car
rover 620ti
Re: 620 Ti??

its ok mate . no i mean like the light works inside car when i open the doors ,but if i drive the car then leave it for coupe of hours it goes flat.
 

turbonutter69

TC ModFather
Moderator
Points
692
Location
Alone in the dark.
Car
Insignia SRI.
Re: 620 Ti??

its ok mate . no i mean like the light works inside car when i open the doors ,but if i drive the car then leave it for coupe of hours it goes flat.


Ok mate but I meant all your electric like heaters, rear window heater electric windows, seat etc???
And thats some good info there prince good find mate.
 

herb

modherbrator
Moderator
Points
487
Location
west midlands
Car
Seat Leon Cupra
Re: 620 Ti??

i had a similar issue with my first nova first thing i changed was the battery still happened second thing i changed was the alternator so i took it back it happened again took it back and the chap actually took the alternator of his nova but yet it happened again so out came the multimeter and a good few hours later i traced the fault to a broken track in the instrument panel

so at a guess you have a broken or loose wire somewhere mate are you any good with a multi meter ?? if not its time for an auto electrician mate
 

azzy

Torque Junkie
Points
65
Location
sheffield
Car
rover 620ti
Re: 620 Ti??

yes am having same probs mate how did u find ur fault where did u find it. yes i can use meter testers wat do i test
 

herb

modherbrator
Moderator
Points
487
Location
west midlands
Car
Seat Leon Cupra
Re: 620 Ti??

yes how do i set it on continuity settings wats the volts called on meter. dc 20
no mate testing continuity isnt done through measuring the voltage it basicly allows you to test if their is a break in the circuit/wire
if you have a digital meter it should be one over from the ohms setting its the 1 where if you touch the 2 probe together it makes a bleep noise
but if you are using an analogue meter you use the ohms setting and when you touch the 2 probes together the needle should move
hope this makes sense im finding it hard to type an explanation
 

azzy

Torque Junkie
Points
65
Location
sheffield
Car
rover 620ti
Re: 620 Ti??

yeh sorry i get u now yes i got the digital 1 . so i leave it on beep mate for fuses and break in wires. wat if i take 1 wire off the battery and put my volt test on the end of it will that show me anything
 

turbonutter69

TC ModFather
Moderator
Points
692
Location
Alone in the dark.
Car
Insignia SRI.
Re: 620 Ti??

sorry mate can i test the same on temp sensors and others sensors work. with same mode or not

Does your temp gauge work? That shouldn't be causing an issue. I'd first check the relays in the fuse box. But also if something in your car doesn't work ie heaters or electric mirrors then this could be the cause as well?
 

herb

modherbrator
Moderator
Points
487
Location
west midlands
Car
Seat Leon Cupra
Re: 620 Ti??

yeh sorry i get u now yes i got the digital 1 . so i leave it on beep mate for fuses and break in wires. wat if i take 1 wire off the battery and put my volt test on the end of it will that show me anything
sorry mate not really sure what you mean but testing for continuity is a long winded and boring process and im not really sure how to explain it mate it is basically testing most of the wires by connecting the probe to 1 end tracing the wire then connecting the other probe to the other end of the wire and seeing if you get the beep from the meter (just a little tip you will need a couple of meters of wire speaker wire is sufficient for when you have to test the longer wires)
 
Similar threads
Thread starter Title Forum Replies Date
A 620ti help 600 19
A Testing a Lambda sensor 620Ti 600 28
turbonutter69 620ti Forum? 600 4
turbonutter69 Where's all the 620ti owners? Any out there? 600 10
turbonutter69 Engine fan 620ti 600 19

Similar threads


Please watch this on my YouTube channel & Subscribe.


Top